Saltar al contenido

Más en DLAN: Nuestras Traducciones | Otras Traducciones | Mods y modding | Revisiones y Guías | Videojuegos | Arte | Literatura | Rol y Rol por foro e IRC | Mapa de la web
Foto

Varitas del CEP y DMFI (bug?)


2 respuestas al tema

#1 Obsidiana

Obsidiana

    Humano

  • Miembro
  • Pip
  • 38 posts

Posteado 11 August 2018 - 10:22 AM

Buenas a todos, desde hace unos días me estoy dando cuenta, que cuando abro x varita de DM (ya sea del cep o de DMFI) las conversación de estas varitas se quedan bugueadas.

 

El problema se da cuando uso x varitas, tras usarlas me salta conversaciones de otras varitas, es muy extraño, he intentado mirar a ver que pasa (si tuviera en el onactivate algo mal o algo) pero no encuentro el fallo.

 

A alguno le ha pasado algo parecido?



#2 Zoraga

Zoraga

    Neonato

  • Miembro
  • PipPip
  • 210 posts

Posteado 12 August 2018 - 07:52 AM

Me ha pasado algo parecido, pero no recuerdo como lo solucioné. Hace algunos temas atrás preguntaste por las varitas en español, y puse unos enlaces con la conversación en español de las varitas, ¿se te buguean con esta conversación?.


Colaborando en:



Nombre servidor: ES) Rebelión del Submundo
Tipo de servidor: rol/acción/jvj
Jugadores: 1-25
Niveles: 1-30
Base literaria: Reinos Olvidados
IP (conectar directamente): sombrasdefaerun.no-ip.org
Foro: http://usn-rol.foroes.org/



 


#3 lavafuego

lavafuego

    Ancillae

  • Miembro
  • PipPipPip
  • 395 posts

Posteado 12 August 2018 - 08:47 PM

Si salta otra conversacion hay algo mal en el script o en los tag/res ref de los objetos. No se como es ese sistema, pero imagino que en los script del modulo, en onactivate item habrá una linea donde identifique el objeto usado:
object oArtefacto =GetItemActivated();

Y en otra linea donde decimos que si se usa el objeto salte la conversacion:
if(GetTag(oArtefacto) == "objeto_usado_que_lanza_conversacion")
{

AssignCommand(oJugador, ActionStartConversation(oJugador, "conversacion_que_lanza", TRUE));
return;
}


Normalmente se usa el mismo tag del objeto para la conversacion asi no da errores. Echale un ojo a ver si es eso. Estoy sin aurora y son todo conjeturas no he podido mirar el sistema de las varitas si es asi o un script que se dispara de otra forma
Pero me huele a error tag/res ref del objeto o nombre de conversacion

Editado por lavafuego, 12 August 2018 - 08:52 PM.

http://tierrasdenemar.mi-foro.es/  (abierto para test 79.109.30.79:5121 )




Responder



  


A Bragol. Tus amigos te echan de menos.