Saltar al contenido

Más en DLAN: Nuestras Traducciones | Otras Traducciones | Mods y modding | Revisiones y Guías | Videojuegos | Arte | Literatura | Rol y Rol por foro e IRC | Mapa de la web
Foto

Error Bloodlines: Node graph out of date


10 respuestas al tema

#1 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 10 May 2016 - 07:24 PM

Buenas tardes a todos.

 

Este es mi primer post en este foro, y es para preguntar si alguien conoce la solución a un error que me está sucediendo al jugar al Vampire: The Masquerade Bloodlines. Aunque hace muchos años lo jugué en un ordenador antiguo, hace un par de días compré la edición de GOG.com, aplicando el Spanish Patch Pack v1.5.1. que puede descargarse en este mismo foro (solo la primera opción, pues no quería ninguna modificación aparte de la traducción). He aquí que, cada vez que entro en una nueva área, me aparece el siguiente mensaje de error:

 

"Node graph out of date. Rebuilding... I.A. disabled".

 

Al principio pensaba que era un error molesto sin más, pero al ir jugando he detectado algunos comportamientos extraños en algunos PNJ, como quedarse totalmente inmóviles cuando deberían moverse, o atacarme sin ningún motivo. ¿Alguien sabe a qué se debe y cómo puedo solucionarlo?

 

Muchas gracias por adelantado.


«No olvides que el Diablo reconoce a los suyos».


#2 MenemDoIt

MenemDoIt

    Antediluvian

  • Miembro
  • PipPipPipPipPip
  • 1096 posts

Posteado 10 May 2016 - 07:53 PM

a mi me pasaba lo mismo en el Half Life 2, el mismo mensaje y todo. si ya buscaste en google y no encontraste la solucion, podrias probar de aplicar el mismo " fix " que me funciono a mi en el HL2, aunque seguramente el archivo a modificar sea otro, pero dado que el mensaje de error es el mismo y te ocurre lo mismo que me ocurria a mi, he de suponer que usan el mismo engine ( o uno similar ).

 

Here is the solution for A.I.disabled bug:

Go into your hl2\cfg\ folder, and create a txt file, inside this
text file, write the following lines.

ai_norebuildgraph "1"
ai_disable "0"

Save, then rename the text file to ai_fix.cfg, right click the file
and set it to read only.

Next, open up valve.rc in notepad, you should see the following
// load the base configuration
//exec default.cfg
// Setup custom controller
exec joystick.cfg
// run a user script file if present
exec autoexec.cfg
//
// stuff command line statements
//
stuffcmds
// display the startup level
startupmenu

under "exec autoexec.cfg", add this line
exec ai_fix.cfg

Save the file and your done

 

 

 

¿se entiende o te lo traduzco al español?


10016077DS1515734551.gif


#3 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 10 May 2016 - 07:59 PM

Muchas gracias por la respuesta.

 

Tranquilo, entiendo perfectamente el inglés. Lo que ya me cuesta un poco más es seguir todas esas indicaciones que me suenan a chino. Me da miedo desgraciar el juego o algo... Pero iré paso a paso. Ya te comento si consigo algo.


«No olvides que el Diablo reconoce a los suyos».


#4 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 10 May 2016 - 09:45 PM

Pues la verdad es que no consigo nada. El primer paso (la creación del archivo .cfg) ya lo he hecho, pero no sé dónde integrar la orden de ejecutar dicho .cfg. No veo ningún archivo que contenga ordenes... Es frustrante T_T . No sé qué hacer.


«No olvides que el Diablo reconoce a los suyos».


#5 MenemDoIt

MenemDoIt

    Antediluvian

  • Miembro
  • PipPipPipPipPip
  • 1096 posts

Posteado 10 May 2016 - 10:35 PM

podrias probar de buscar la palabra clave "exec" dentro del contenido de todos los archivos del juego, llevaria unos minutos, pero seria mas facil que buscar a mano.

 

por supuesto me refiero a un programa que haga la busqueda, claro, no se si el buscador del sistema operativo que tengas servira, pero tal vez el de otro programa ( como WinRAR o similares ) si sirva.


Editado por MenemDoIt, 10 May 2016 - 10:36 PM.

10016077DS1515734551.gif


#6 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 10 May 2016 - 11:14 PM

Vale, ya he hecho lo que me has sugerido. Esto puede parecer muy extraño, pero en todo mi ordenador no hay ni un solo archivo que contenga las palabras "exec autoexec.cfg". De hecho, no aparece ninguno de los comandos que listas en tu explicación. Curiosamente, en la carpeta del juego sí hay un archivo llamado "autoexec.cfg". Esto es muy raro... Mucho me temo que esto no va a ser fácil de solucionar.


«No olvides que el Diablo reconoce a los suyos».


#7 MenemDoIt

MenemDoIt

    Antediluvian

  • Miembro
  • PipPipPipPipPip
  • 1096 posts

Posteado 10 May 2016 - 11:35 PM

yo decia solo buscar "exec" dado que es la orden de ejecutar otro archivo, si encontras un archivo que contenga la palabra "exec" entonces podrias añadirle a ese archivo la linea y el nombre del archivo que creaste.

 

la otra opcion mas complicada sera revisar manualmente todos los archivos ".cfg" dentro del directorio del juego, filtra el buscador para que solo te muestre los archivos con esa extension y buscas manualmente la palabra "exec" dentro de ellos, si el buscador integrado del windows u otro programa no busca correctamente dentro de los archivos.

 

no se si resulte pero tambien podrias probar de escribir en la consola del juego los comandos del archivo ( ai_norebuildgraph "1" y ai_disable "0", no se si en la consola haran falta las comillas " " ).


Editado por MenemDoIt, 10 May 2016 - 11:39 PM.

10016077DS1515734551.gif


#8 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 10 May 2016 - 11:46 PM

Sí, ya he configurado Windows para que busque dentro del contenido de los archivos, y nada. De hecho, ni siquiera encuentro ningún .cfg que contenga la palabra "exec". Y tengo todos los .cfg localizados, y nada... Intentaré con la consola, a ver qué pasa.

 

Muchas gracias por tu paciencia y tu ayuda...


«No olvides que el Diablo reconoce a los suyos».


#9 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 11 May 2016 - 01:12 AM

Con la consola no funciona... Voy a intentar desinstalar e instalar el juego por cuarta vez, y trataré de introducir los famosos comandos en todos los .cfg, uno a uno, hasta que funcione. En algunos he visto que algo hacía, pero lo contrario a lo que quería (me dejaba a todos los personajes inmóviles y mudos, y anulaba todos los scripts). A ver si mañana tengo suerte...


«No olvides que el Diablo reconoce a los suyos».


#10 Ian McMillan

Ian McMillan

    Humano

  • Miembro
  • Pip
  • 9 posts

Posteado 11 May 2016 - 09:54 AM

¡AL FIN LO HE CONSEGUIDO!

 

Después de mil y una pruebas, instalaciones y desinstalaciones, alteraciones de .cfg y demás, he dado con la tecla exacta. Dejo aquí lo que a mí me ha servido:

 

1. Instala el juego de GOG.com (viene de serie con el parche 9.5).

 

2. Instala el Spanish Patch Pack v1.5.1, que traduce el juego y arregla bugs. Personalmente, al instalar este paquete de parches, yo he elegido también los parches opcionales 1 y 2, que no alteran el contenido del juego, sino que solo arreglan bugs que pueden impedir finalizar misiones secundarias.

 

3. Ve al archivo "autoexec.cfg" (por defecto está en C:/GOG Games/VtMB/Unofficial_Patch/cfg). Ábrelo y, al final del todo, añade la línea "ai_norebuildgraph "1". Guarda los cambios y cierra el archivo. Problema resuelto.

 

Nota: No escribas "ai_disable "0", ya que lo anterior soluciona ambos problemas (el de "Node graph out of date. Rebuilding" y el de "A.I. disabled"). Si lo haces, te ocurrirán otros bugs en el juego. Por ejemplo, en la introducción, después del juicio, los vampiros se quedarán inmóviles, no abandonarán el teatro y la intro se quedará congelada ad æternum. Si te saltas la intro con la consola, comprobarás que todos los PNJ del juego están quietos y no saltan los diálogos automáticos. Por eso, escribe solamente la orden "ai_norebuildgraph "1".


«No olvides que el Diablo reconoce a los suyos».


#11 Runspect

Runspect

    Elder

  • Miembro
  • PipPipPipPip
  • 974 posts

Posteado 14 May 2016 - 01:44 PM

Estupendo. He añadido un enlace a este post en mi pack, por si alguien tiene este mismo error.





Responder



  


A Bragol. Tus amigos te echan de menos.